Trabalho de Electrénica de Poténcia Mestrado em Electrénica Industrial

Conversores CC-CC com Isolamento Eléctrico

Objectivo

Utilizando o simulador PSpice 8.0 pretende-se realizar e verificar o funcionamento de
dois conversores CC-CC com isolamento eléctrico: Flyback e Forward.

Conhecimentos Praticos Necessarios

Este trabalho apoia-se na matéria leccionada na disciplina de Electrénica de Poténcia. A
bibliografia recomendada € a dessa disciplina.

PSpice

E um software de simulagdo da MicroSim Corporation que ajuda a andlise de circuitos
eléctricos e electrénicos. Em anexo (anexo 2) é fornecida informagido sobre esta
ferramenta e respectivas instrugdes.

Introducio

Os conversores CC-CC sdo bastante utilizados em fontes de alimentagdo reguladas e em
accionamentos de motores CC. Geralmente, a tensdo de entrada destes conversores ¢
obtida através da rectificagdo CA-CC da tensdo da rede, sendo por isso flutuante devido
as variacGes da tensdo da rede de distribuicio de energia eléctrica. Os conversores
CC-CC s@o usados para converter essa tensio CC ndo regulada, numa tensédo
controlada.

As fontes de tensdo reguladas sdo necessdrias para a maior parte dos sistemas
electrénicos analdgicos ou digitais. Pretende-se que a maior parte delas tenham os
seguintes requisitos:

o Tensdo de saida constante (dentro de uma tolerincia pré-definida) para variagcdes
dentro da gama especificada da tensio de entrada e da carga.

» Isolamento eléctrico entre a entrada e a saida.

o Muiltiplas saidas isoladas umas das outras.

Atendendo a estes requisitos, o principal objectivo é reduzir o tamanho da fonte de
tensdo e melhorar a sua eficiéncia. O avango na tecnologia dos semicondutores
permitiu-nos usar fontes de tensdo comutadas, em oposi¢io as fontes de tensio lineares.
Como as fontes comutadas operam a frequéncias elevadas (componentes de filtragem
menores), tornam-se menos pesadas e volumosas.

A comparagdo econdmica entre fontes lineares e comutadas depende da poténcia
necessaria.
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Conversor CC-CC Flyback

Valores nominais:
Vd =32V, vo =4V, D =04, fg = 200kHz, C = 100pF, R oad = 1£2.

Transformador: N]/N2 =4, indutdncia de magnetizagio L;; = 30uH, indutncias de
fugas desprezaveis.

Exercicios:

1. Obtenha as formas de onda de vy, v, i4, € ip.

2. Obtenha as formas de onda de vy, iy, € ip, durante a comutacao.

g . . . I Vo, .. ..
3. Calcule os valor médios de iy, € ip e verifique que 7“ ~ T/‘l (ustifique).
o d

4. Observe a forma de onda de tensdo no interruptor (vsw) com e sem snubber.

. ‘- ~ 2 |4
Verifique que o valor mdximo da tensdo € v, = T—t

5. Modifique os valores dos componentes de modo ao conversor funcionar no modo
de condugdo descontinuo.

6. Verifique o ficheiro de saida de PSpice e procure interpretar os diferentes
comandos nele contidos.
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Notas:

1.

2z

O transformador é representado por um simbolo que se chama
TRANS_NONIDEAL e que se encontra na biblioteca PWR_ELEC.SLB. Uma vez
que as indutincias de fugas sdo desprezdveis, o coeficiente de acoplamento k €
aproximadamente igual a 1 (faga, p. ex., k = 0.999), pelo que:

Li=L,=30uH ¢ I, = 5 = 1.875UH

L
(M)
Admita que o valor inicial da corrente em Lj é 1.17A (faga ICOIL1 =1.17A) e em
Ly € 0A.

Utilize como interruptor electrénico o componente representado pelo simbolo
SWITCH da biblioteca PWR_ELEC.SLB.

Coloque um snubber R-C em paralelo com o interruptor. Faca:

Rsnup = 100Q2, Csyyp = InF

Devido a requisitos de conectividade do PSpice (ndo sdo permitidos néds
flutuantes) deve ligar uma resisténcia de valor elevado (1MQ, p. ex.) entre os nés
3e0.

Seleccione para diodo o subcircuito SW_DIODE_WITH_SNUB identificado pelo
simbolo com 0 mesmo nome da biblioteca PWR_ELEC.SLB (ver anexo 1).

Para produzir o sinal de comando do interruptor utilize o subcircuito
PWM_RAMP e introduza os seguintes valores para os parametros requeridos (ver
anexo 1):

RISE = 4.8us, FALL = 0.1ps, PW = 0.1ps, PERIOD = 5ps.

Para fazer variar o duty cycle D entre 0 e 1, a tensdo de entrada de PWM_RAMP
deve variar entre OV e 1V.

Admita que o valor inicial da tensdo no condensador de saida é 4.15V (faca
IC =4.15V).

Faca a andlise do comportamento do circuito em regime transitério para, p. ex.,
8 periodos de comutagdo com intervalos de tempo de 0.1us.
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Conversor CC-CC Forward

A 0 R S e R
ﬁiﬁﬁq’DIjij, S

-1 o 1
F by Klunear . .
MR COUPLING=D9d999. .

Valores nominais:
Vd =50V, vo =4.5V, D =04, f; = 200kHz, Lf=7.5uH, C = 100uF, R[04 = 1Q.

Transformador: N;/N> =4, Ni/N3 = 1, indutincia de magnetizacgdo L,, = 100uH,
indutancias de fugas desprezaveis.

Exercicios:

1.  Obtenha as formas de onda de if e da tensdo de entrada do andar de saida (ou seja,
a tensdo aos terminas do diodo D>.

2. Obtenha as formas de onda de v}, iy, € i3. Mostre que o valor médio de v; € igual
a zero.

t N .
3. Mostre que = = ﬁ D, onde t,, € o intervalo de tempo durante o qual D3 conduz.
N 1

4. Modifique (menu Edit Model) os pardmetros modelo do diodo D3
(POWER_DIODE) para: Cjo = 0.001fF, Is=1E-6A, Rs=0.01Q. Observe de
novo a forma de onda de v;. Que conclui?
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Notas:

1. O transformador de 3 enrolamentos é representado por 3 indutancias L;, Ly e L3,
com acoplamento magnético quase perfeito. Utilize o simbolo K_Linear da
biblioteca de simbolos ANALOG.SLB para definir o acoplamento linear entre as
3 indutincias. Uma vez que as indutincias de fugas sdo desprezdveis, o coeficiente
de acoplamento & € aproximadamente igual a 1 (faga, k = 0.99999), pelo que:

L L
L =L =100uH, = =6.25UH = =100
e 7TV T A A

2. Devido a requisitos de conectividade do PSpice (nfo sdo permitidos nds

flutuantes) deve ligar uma resisténcia de valor elevado (1MQ, p. ex.) entre os nés
4e0.

3. Seleccione para diodos D; e Dy o subcircuito SW_DIODE_WITH_SNUB
identificado pelo simbolo com o mesmo nome da biblioteca PWR_ELEC.SLB
(ver anexo 1).

4. Seleccione para diodo D3 o subcircuito POWER_DIODE da mesma biblioteca.

W

Para produzir o sinal de comando do interruptor utilize o subcircuito
PWM_RAMP e introduza os seguintes valores para os pardmetros requeridos (ver
anexo 1):

RISE = 4.8ps, FALL = 0.1ps, PW = 0.1ps, PERIOD = 5ys.

Para fazer variar o duty cycle D entre 0 e 1, a tensdo de entrada de PWM_RAMP
deve variar entre OV e 1V.

6.  Considere que o valor inicial da corrente da indutincia de saida (Ly) é 3A e que o
valor inicial da tensao de saida é 4.5V.

7. Faga a andlise do comportamento do circuito em regime transitério para um
intervalo de tempo de 0 a 20ps, com intervalos de tempo de 0.1us. Ndo permita
intervalos de simulagio superiores a 0.01ps.
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ANEXO 1- Modelos dos Subcircuitos

SUBCKT DIODE_WITH_SNUB

Objective: This subcircuit is used to represent line-frequency
diodes.
NN jo
T Vvl
0.1uF 1k

Input Circuit File Listing:

.SUBCKT DIODE_WITH_SNUB 101 102

* Power Electronics: Simulation, Analysis & Education.....by N. Mohan.
DX 101 102 POWER_DIODE

RSNUB 102 103 1000.0

CSNUB 103 101 0.1uF

.MODEL POWER_DIODE D(RS=0.01, CJO=100pF)
.ENDS

SUBCKT SW_DIODE_WITH_SNUB

Objective: This subcircuit is used to represent sitching-
frequency diodes.

®__,

% <
onF | %0

Input Circuit File Listing:

.SUBCKT SW_DIODE_WITH_SNUB 101 102

* Power Elcctronics: Simulation, Analysis & Education.....by N. Mohan.

DX 101 102 POWER_DIODE

RSNUB 102 103 100.0

CSNUB 103 101 10nF ,

.MODEL POWER_DIODE D(CJO=0.001{F, IS=1E-6, RS=0.01)

.ENDS
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B ' SUBCKT SWITCH

7

Objective: This subcircuit is used to represent voltage-
controlled switches through which the current is
unididirectional.

8
o

1
swW

Input Circuit File Listing:

SUBCKT SWITCH 101 103 150 100

* Power Elcctronics: Simulation, Analysis & Education.....by N. Mohan.

SW 101 102 15) 100 AC_SWITCH

DSW 102 103 POWER_DIODE

.MODEL AC_SWITCH  VSWITCH ( RON=0.01)

.MODEL POWER_DIODE D(CJO=0.001[F, IS=1E-6, RS=0.01)
.ENDS

SUBCKT TRANS_NONIDEAL

Objective: A nonideal tranformer.

icoil 1 K12 icoUZ' @

COIL 1 COIL 2

Input Circuit File Listing:

SUBCKT TRANS_NONIDEAL 101 102 103 104 PARAMS: ICOIL1=1A ICOIL2=1A
* Power Electronics: Simulation, Analysis & Education.....by N. Mohan.

LCOLL1 101 102 (L1} IC={ICOL1}
LCOIL2 103 104 (L2} IC={ICOLL2]
K12 LCOLL1 LCOIL2 (k)
ENDS
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Objective: This subcircuit is used for PWM control of single-
switch dc-dc converters.

------- _(®

VCONﬁ'L ! PWM_RAMP!

lse Width
a ) ®

v

VRAMP ] Vo VRAMP a EGATE
IMEG IMEG
oV > -
—  Peiiod e tme
EGATE
f
10V —+
ov 11 -
ooosv N 0.005 v (v oy VRAMP)

-~ -1.0V

ov
Input Circuit File Listing:
.SUBCKT PWM_RAMP 150 100 152
* Power Electronics: Simulation, Analysis & Education.....by N. Mohan.
RCNTL 150 100  IMEG
RRAMP 151 100 IMEG
VRAMP 151 100 PULSE(0 1V 0 {RISE} {FALL} {PW} {PERIOD})
EGATE 152 100 TABLE { V(150) - V(151) } =(-1.0,-1.0) (-0.005,-1.0) (0.0,0.0)
+ (0.005,1.0) (1.0 , 1.0)
RGATE 152 100 IMEG
.ENDS
Note: A finite pulse width PW is used to avoid voltage

convergence problems.
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ANEXO 2

Informacao sobre o PSpice
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Simulation Examples

Chapter Overview

The examples in this chapter provide an introduction to the
methods and tools for entering circuit designs, running
simulations with PSpice, and analyzing simulation results using
Probe. All analyses are performed on the same example circuit.
This allows for a clearer illustration of analysis setup,
simulation, and result analysis procedures for each analysis

type.

This chapter includes the following sections:

Probe Performance Analvsis on page 2-28




2-2 Simulation Examples

New icon:

Shortcut: Click on [Z4¢] or press

If you have enough room on your
screen, click on Place to leave
the Part Browser dialog box
open.

Example Circuit Design
Entry

This section describes how to use MicroSim Schematics to enter
the simple diode clipper circuit shown in Figure 2-1.

Figure 2-1 Diode Clipper Circuit

To open a new schematic window

1 Start Schematics. If Schematics is already running, be sure
you are in the schematic editor.

2 Ifyouare in a blank schematic window (indicated by “new”
in the title bar at the top of the window), you can begin
entering the circuit.

If you need to open a new schematic window, click the New
icon or select New from the File menu.

To place the voltage sources

1 Seclect Get New Part from the Draw menu to display the Part
Browser dialog box.

Type vpc in the Part Name text box.
Click on Place & Close.

Move the cursor to position the source at the desired
location on the schematic page.



Example Circuit Design Entry 2-3

5 Click to place the first source.
6 Move the cursor and click again to place the second source.

7 Right-click to end placement mode.

To place the diodes

1 Go to the Part Browser dialog box. If needed, click on
. redisplay the Part Browser dialog
2 Type p1N39* in the Part name text box. box.
3 Press to display a list of diodes. When placing components:
4 Click on DIN3940. » Leave space to connect the
. . ith wires.
5 Click on Place (to leave the dialog box open) or Place & comp.onents with wires
Close (to close the dialog box). s It device names and values
don’t match the names
6 Press(Cti}+ " to rotate the diode outline to the desired shown in Figure 2-1, they can
orientation. be changed later.

7 Click to place the first diode (D1), and click again to place
the second diode (D2).

8 Right-click to end placement mode.

To move the text associated with the diodes (or
any other object)

1 Click once on the text to select it. Select Redraw from the View
menu or press (Ctri}+ . to redraw

2 Drag the text to the desired location. the circuit as necessary

To place the other components

Follow similar steps as described for the diodes to place the
components listed below. The symbol names you need to type
in the Part name text box of the Part Browser dialog box are
shown in parentheses.

1  resistors (R)
2 capacitor (C)
3 ground symbols (EGND)

4 bubble symbols (8UBBLE)



2-4 Simulation Examples

Shortcut: Click on
(Ctr)+w.

You can right-click at any time to
stop the wiring mode. The cursor
changes to the default arrow.

If necessary, double-right click or
press to resume wiring
mode. The cursor changes back
to a pencil.

Clicking on any valid connection
point terminates a wire. A valid
connection point is shown as an
“X” (see Figure 2-2).

R1
O—x A
Tk
Figure 2-2 Connection Points

If you make a mistake when
placing or connecting
components:

1 Click on the wire or
component.

2 Press (Del.

Bubbles serve as “wireless”
connections where connectivity
is implied by identical labels.

To connect the components

1

Select Wire from the Draw menu to enter wiring mode. The
cursor changes to a pencil.

Click on the connection point (the very end) of the pin on the
bubble at the input of the circuit.

Click on the nearest connection point of the input resistor
RI.

Connect the other end of R1 to the output capacitor.

Connect the diodes to each other and to the wire between
them:

a Click on the connection point of the anode for the lower
diode.

b Move the cursor straight up and click on the wire
between the diodes. The wire terminates and the
junction of the wire segments is made visible.

¢ Click again on the junction to continue wiring
d Click on the end of the upper diode’s cathode pin.

Continue connecting components until the circuit is wired
as shown in Figure 2-1 on page 2-2.

To assign names (labels) to the nets and bubbles

1

Double-click on any segment of the wire which connects
R1, R2, R3, the diodes, and the capacitor.

Type Mid in the Label text box.
Click on OK.

Double-click on each bubble to label it as shown in
Figure 2-1 on page 2-2.
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To place the viewpoint symbol

1 Type viEWPOINT in the Part Name text box of the Part
Browser dialog box.

2 Place the viewpoint so that its connection point (pin end)
touches the wire labeled Mid.

To assign a name to a device

A particular name can be assigned to a device in the schematic Example; assigning the name

(like “Vin” for a VDC, or Cout for the capacitor) as follows: “Vin” for the second VDC.

1 Double-click on the reference designator for the device. 1 Double-click on the reference
designator of the VDC

2 Type the new name in the Edit Reference Designator dialog symbol, V2.

box. 2 Type vin in the Edit

3 Click on OK. Reference Designator dialog
box.

To change the value of a device 3 Click on OK.

1 Double-click on the value for the device.
2 Type the new value in the Edit Value dialog box.
3 Click on OK.

To save your schematic

1 Select Save from the File menu. Shortcut: Click on

(Ctri)+s.

2 Type cLIpPpER as the schematic file name.

3 Click on OK to save the file as clipper.sch.



2-6 Simulation Examples

Shortcut: Click on
F11).

Bias Point Analysis

Running PSpice

After creating the schematic clipper.sch, you can run PSpice
by selecting Simulate from the Analysis menu. PSpice performs
the simulation and generates the output file (clipper.out).

While PSpice is running, the progress of the simulation is
displayed in the PSpice simulation status window (see
Figure 2-3).

Eile

Display Help

Writing resuits to WITTEAO]]

Calculating bias point
Bias point calculated

Figure 2-3 PSpice Simulation Status Window
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Simulation Output File

The simulation output file acts as an audit trail of the simulation.
This file optionally echoes the contents of the circuit file as well
as the results of the bias point calculation. If there are any syntax
errors in the netlist declarations or simulation directives or
anomalies while performing the calculation, error and/or
warning messages are written to the output file.

To view the simulation output file
1 Close the PSpice window.

2 In Schematics, select Examine Output from the Analysis
menu to display the output file in the MicroSim text editor
window. Figure 2-4 shows the results of the bias point
calculation as written in the simulation output file
(clipper.out).

3 When finished, close the MicroSim text editor window.

* C:N\TUTORIAL\CLIPPER sch

Ll SMALL SIGRAL BIAS SOLUTION TEMPERATURE = 27.000 DEG C

NODE  VOLTAGE NODE  VOLTAGE NODE  VOLTAGE NODE  VOLTAGE

{ In) 0.0000 { Mid) 9434 ( Out) 0.0000 ( Vcc) §.0000

VOLTAGE SOURCE CURRENTS
NAME CURRENT

v_vi -1.229E-03
V_Vin 9.434E-04

TOTAL POWER DISSIPATION

6.15E-03 WATTS

Figure 2-4 Simulation Output File

Since the diodes are both reverse biased (off), and the input
source Vin is OV (a short circuit to ground), the bias point is
dependent only on the values of VCC, R1, R2, and R3.

The voltage at net Mid is in
agreement with manual
calculation:

R
V(MID) = l6%]><vcc
where:
Req = RIXR3
“d = RT+Req

Correct, expected bias point
analysis results provide
assurance of proper circuit
connectivity.
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Note that the current through VIN is negative. By convention,
PSpice measures the current through a two terminal device into
the first terminal and out of the second terminal. For voltage
sources, current is measured from the positive terminal to the
negative terminal; this is opposite to the positive current flow
convention and results in a negative value.

Voltage Viewpoint

The VIEWPOINT symbol was initially a blank line. When the
simulation is finished and bias point voltages are available, the
viewpoint reflects the voltage at the net to which it was

connected (in this case, the voltage at the node Mid is 0.9434).
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Shortcut: press (Cri)+><.

If your version of Schematics
does not include the Stimulus
Editor (Basics users):

1 Place a VSIN symbol instead
of VSTIM.

2 Double click on it.

3 Double-click on the
appropriate attributes to set
their values as VOFF,
VAMPL, and FREQ. Click on
Save Attr or press after
entering each attribute’s
value to accept the changes.

4 Click on OK.

Transient Analysis

This example shows how to run a transient analysis on the
clipper circuit. This requires adding a time-domain voltage
stimulus as shown in Figure 2-11.

© 01

) S‘M.I:LU:S-:SN:E s

Figure 2-11 Diode Clipper Circuit with a Voltage Stimulus

To add a time-domain voltage stimulus

1 In Schematics, select Clear All from the Markers menu.

2 Select the ground symbol beneath the VIN source.

3 Select Cut from the Edit menu.

4 Scroll down or select Out from the View menu (or click on
the Zoom Out icon).

5 Place a VSTIM symbol as shown in Figure 2-11.

6 Select Paste from the Edit menu.

7 Place the ground symbols as shown in Figure 2-10.

8 Select Fit from the View menu.

9 Select Save As from the File menu, and save the file as

clippert.sch.

10 Double-click on the VSTIM symbol to start the Stimulus
Editor.
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11 When prompted to name the stimulus, type sINE and click
on OK.

12 Inthe New Stimulus dialog box of the Stimulus Editor, click
on SIN, and click on OK.

13 In the Stimulus Attributes dialog box, set the first three
parameters as follows:

Offset Voltage =0
Amplitude = 10
Frequency = 1kHz

14 Click on Apply to view the waveform. The Stimulus Editor
window should look like Figure 2-12.

Figure 2-12 Stimulus Editor Window
15 Click on OK.

16 Click on the Save icon or press Shif|-+HF12] to save the Save icon:
stimulus information.

17 Select Exit from the File menu.
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To set up and run the transient analysis

Analysis Setup icon: 1 In Schematics, click on the Analysis Setup icon or select
Setup from the Analysis menu to display the Analysis Setup

dialog box.

T 1 2 Click on Transient to display the Transient Analysis dialog
box.

Set up the Transient dialog box as shown in Figure 2-13.
Click on OK.

If needed, click on Transient check box in the Analysis
Setup dialog box so that it is checked on (enabled).

6 If needed, disable DC sweep from the previous example by
clicking on the DC Sweep check box so that it is not
checked.

DC Sweep is disabled here so that you can see the results of
a transient analysis run by itself. PSpice can run multiple
analyses during simulation, and you could run both DC
sweep and transient analyses.

Figure 2-13 Transient
Analysis Dialog Box
Click on Close to exit the Analysis Setup dialog box.

Save icon: ¥ Click on the Save icon.

) ] i Click on the Simulate icon or press to start the
Simulate icon: |31 simulation.

PSpice uses its own internal time steps for computation. The
internal time step is adjusted according to the requirements of
the transient analysis as it proceeds. Data is saved to the Probe
data file for each internal time step.

Note The internal time step is different from the Print
Step value. Print Step controls how often optional
text format data is written to the simulation output
file (.out).
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To display the output variable list with aliases This portion of the example

and display desired traces in Probe describes how to view the input
sine wave and the clipped wave
1 Select Add from the Trace menu. (You can also click on the at Out. The output variable list is
Add Trace icon or press (Insert).) used as an alternative to
markers to select the traces to be
displayed.

N

Select V(Out) and V(In) by clicking on them in the trace list.

w

Click on OK. The traces are displayed.

>

Place the symbols shown in the trace legend on the traces
themselves as shown in Figure 2-14:

a Select Options from the Tools menu.

b Click on Always in the Use Symbols portion of the
dialog box.

¢ Click on OK.

5 Click on the Save icon. Save icon:

These waveforms illustrate the
clipping of the input signal.

0 U(In} » U(Mid)

Time

Figure 2-14 Sinusoidal Input and Clipped Output Waveforms
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ANEXO - Modelos dos Subcircuitos

SUBCKT DIODE_WITH_SNUB |

Objective: This subcircuit is used to represent line-frequency
diodes.
@ J©
l/l |
0.1uF tk

Input Circuit File Listing:

.SUBCKT DIODE_WITH_SNUB 101 102

* Power Elcctronics: Simulation, Analysis & Education.....by N. Mohan.
DX 101 102 POWER_DIODE

RSNUB 102 103 1600.0

CSNUB 103 101 0.1uF

.MODEL POWER_DIODE D(RS=0.01, CJO=100pF)
.ENDS

SUBCKT SW_DIODE_WITH_SNUB

Objective: This subcircuit is used to represent sitching-
frequency diodes.
!s. N ,A!
g
]
10 nF 250
Input Circuit File Listing:
.SUBCKT SW_DIODE_WITH_SNUB 101 102
* Power Electronics: Simulation, Analysis & Education.....by N. Mohan.
DX 101 102  POWER_DIODE
RSNUB 102 103 100.0
CSNUB 103 101 10nF
.MODEL POWER_DIODE D(CJO=0.001(F, IS=1E-~6, RS=0.01)
ENDS
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/

SUBCKT SWITCH

Objective: This subcircuit is used to represent voltage-
controlled switches through which the current is

unididirectional.
O

6
AN

Input Circuit File Listing:

SUBCKT SWITCH 101 103 150 100

* Pawer Elcctronics: Simulation, Analysis & Education.....by N. Mohan.

SW 101 102 150 100 AC_SWITCH

DSW 102 103 POWER_DIODE

.MODEL AC_SWITCH  VSWITCH ( RON=0.01)

.MODEL POWER_DIODE D(CJO=0.001F, IS=1E-6, RS=0.01)
.ENDS

SUBCKT TRANS_NONIDEAL '

Objective: A nonideal tranformer. |

JL

COIL 1 COIL 2

Input Circuit File Listing:

SUBCKT TRANS_NONIDEAL 101 102 103 104 PARAMS: ICOIL1=1A ICOIL2=1A
* Power Electronics: Simulation, Analysis & Education.....by N. Mohan.

LCOIL1 101 102 {L1}  IC={ICOIL1)
LCOIL2 103 104 {L2)  IC={ICOIL2)
K12 LCOIL1 LCOIL2 {k)

.ENDS
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- PWM_RAMP

Objective: This subcircuit is used for PWM control of single-
switch dc-dc converters.

------- _(®

VCONTL 1 PWM_RAMP!

’)’ulseWidlh @
v
VRAMP ] —veorwa VRAMP 0 EGATE
IMEG IMEG
ov ™ time =
- |
EGATE
1oV
oV 1 l -
ooosv — | N 0,005V (v oy VRAMP)
-1.0V
ov
Input Circuit File Listing:
.SUBCKT PWM_RAMP 150 100 152
* Power Electronics: Simulation, Analysis & Education.....by N. Mohan.
RCNTL 150 100  1MEG
RRAMP 151 100  IMEG
VRAMP 151 100 PULSE(0 1V O {RISE} {FALL} {PW} {PERIOD})
EGATE 152 100 TABLE { V(150) - V(I51) } = (-1.0,-1.0) (-0.005,-1.0) (0.0,0.0)
+ (0.005,1.0) (1.0 , 1.0)
RGATE 152 100  IMEG
.ENDS
Note: A finite pulse width PW is used to avoid voltage

convergence problems.
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